PLEX Vault and New Eden Store Unavailable

Incident Report for EVE Online

Resolved

The NES is now accessible and issues relating to the PLEX vault and character loading times have been resolved. TQ is back to fully operational.

If anyone was affected by the PLEX vault and believe their balance is incorrect then please contact support via (support@eveonline.com)
Posted Oct 03, 2023 - 12:02 UTC

Update

We're also seeing reports of longer than usual loading times after selecting character.
Posted Oct 03, 2023 - 11:49 UTC

Investigating

Currently we're seeing issues with players using their PLEX vault and accessing the New Eden Store. More information to follow.
Posted Oct 03, 2023 - 11:41 UTC
This incident affected: Tranquility (Game Server).