Epic Login Error

Incident Report for EVE Online

Resolved

This incident has been resolved.
Posted Jan 28, 2026 - 13:22 UTC

Monitoring

The issue seems to have been rectified internally. We'll continue to monitor for a short while longer for any further issues.
Posted Jan 28, 2026 - 13:19 UTC

Identified

We believe a solution has been found and we’re testing it now.
Posted Jan 28, 2026 - 13:17 UTC

Update

We think we’ve found a logic issue between the Epic login and Single Sign-On (SSO). We’re continuing to narrow down the specifics of the issue.
Posted Jan 28, 2026 - 12:41 UTC

Update

The investigation is still in progress.
Posted Jan 28, 2026 - 11:57 UTC

Investigating

We're currently investigating issues with the Epic login that are causing an error message to be displayed.

We’re currently investigating the cause of the issue and potential resolutions. We'll be sharing more information as it becomes available.
Posted Jan 28, 2026 - 11:13 UTC
This incident affected: Tranquility (Login).