Paypal temporarily disabled in the EVE store
Incident Report for EVE Online
Resolved
No further issues and therefore we will close this incident as resolved.
Posted Jan 13, 2024 - 10:53 UTC
Update
Paypal payments have been re-enabled and we are monitoring it to ensure it’s working properly.
Posted Jan 12, 2024 - 15:04 UTC
Monitoring
Due to a technical issue downstream from CCP, we have had to temporarily disable Paypal as a payment option in the EVE Online store (https://secure.eveonline.com). We will re-enable the option as soon as the issue is resolved by our partners.
Posted Jan 11, 2024 - 18:31 UTC