Unscheduled Extended Downtime

Incident Report for EVE Online

Resolved

Tranquility is back online!
Posted Nov 19, 2025 - 11:32 UTC

Identified

Initial update didn't go as intended; today's update is currently being re-applied to the server.
Posted Nov 19, 2025 - 11:28 UTC

Investigating

Downtime today for Tranquility will be extended. This is an unscheduled extended downtime. We apologize for any inconvenience. We will post updates on when we expect Tranquility to be open for players on status.eveonline.com. #tweetfleet
Posted Nov 19, 2025 - 11:17 UTC
This incident affected: Tranquility (Game Server, Quasar, Login).