Connection Issues with Tranquility

Incident Report for EVE Online

Resolved

This incident has been resolved.
Posted Jun 06, 2025 - 11:40 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 06, 2025 - 11:21 UTC

Investigating

We're aware of an issue that is currently impacting the ability to successfully connect to Tranquillity, and we are investigating the cause.
Posted Jun 06, 2025 - 11:20 UTC
This incident affected: Tranquility (Game Server, Login).