Unscheduled Extended Downtime

Incident Report for EVE Online

Resolved

Tranquility is back online!
Posted 14 days ago. Mar 18, 2025 - 11:42 UTC

Investigating

Downtime today for Tranquility has been extended. This is an unscheduled extended downtime. We apologize for any inconvenience. We will post updates on when we expect Tranquility to be open for players on status.eveonline.com. #tweetfleet
Posted 14 days ago. Mar 18, 2025 - 11:30 UTC
This incident affected: Tranquility (Game Server).