Tranquility is down

Incident Report for EVE Online

Resolved

Tranquility is online and accepting connections
Posted May 13, 2026 - 13:11 UTC

Investigating

Tranquility is currently down and not accepting connections, our teams are investigating and will update as we have more information.
Posted May 13, 2026 - 13:04 UTC
This incident affected: Tranquility (Game Server, Login).