Account Management and Payment Processing Maintenance
Incident Report for EVE Online
Resolved
Payments and Account Management (https://secure.eveonline.com/) are back online. We're sorry that this took way longer than expected. Thanks again for your patience.
Posted Feb 15, 2024 - 11:30 UTC
Update
Maintenance is taking longer than expected. Payments and access to account management (https://secure.eveonline.com/) continue to be disrupted. We will keep you informed. Thanks for your patience.
Posted Feb 15, 2024 - 10:52 UTC
Monitoring
We will be performing some updates to our payment processing and account management. We expect the update to take around 15 minutes. The update will start at 10:30 UTC February 15. During this time, payments and account management may be disrupted. #EVEOnline #Tweetfleet
Posted Feb 15, 2024 - 10:21 UTC