Log into your account via Steam sign-in is currently unavaiable

Incident Report for EVE Online

Resolved

Steam sign-in services appear to be back to fully operational, this issue is now being marked as resolved.
Posted Feb 12, 2025 - 15:30 UTC

Monitoring

Attempting to login via Steam appears to once again be functional. We'll continue to monitor the situation.
Posted Feb 12, 2025 - 15:13 UTC

Identified

Steam's OpenID service is currently unavailable, preventing Steam sign-in capabilities. We are awaiting further information from Steam about its status.
Posted Feb 12, 2025 - 14:13 UTC

Investigating

We are aware of an issue that prevents logging into your account via Steam's sign-in service. Users will still be able to start the launcher from Steam, and play; however, signing in will not currently function via Steam.
Posted Feb 12, 2025 - 13:18 UTC
This incident affected: Tranquility (Login).