Unscheduled Extended Downtime
Incident Report for EVE Online
Resolved
Tranquility server is now open for players.
Posted Jul 24, 2024 - 11:32 UTC
Investigating
We have an unscheduled extended downtime. We hope to have the server open to players at around 11:30 UTC. #EVEOnline #Tweetfleet
Posted Jul 24, 2024 - 11:16 UTC
This incident affected: Tranquility (Game Server, Quasar, Login).